Ask a Question

Are the search results for FHIR R4 DocumentReference supposed to be paged?

I'm making a GET call to <https://sandbox.healthgorilla.com/fhir/R4/DocumentReference?_lastUpdated=gt2022-08-01T00:00:00.000Z&_offset=0&_count=10> but getting all the resources (over 700) in the response body instead of just 10. Is this the expected behavior?

Result Status Calculation

How to determine status of a report with multiple OBR and OBX with ranging their status from P,X,F. Can you please tell me that rule that HealthGorilla uses?



Error Updating Allergies

im trying to update an allergy created in the portal, when the PUT endpoint is called i receive the following error: &#123; "resourceType": "OperationOutcome", "issue": [ &#123; "severity": "error", "code": "processing", "diagnostics": "substance cannot be modified." &#125; ] &#125; The substance has not been modified, only a reaction has been added. I've tried to update the Allergy without modifying it (sending in the PUT the same data i receive in the GET), But i still receive the same error. Allergy to be updated: &#123; "resourceType": "AllergyIntolerance", "id": "7023d85de188facfe5985755", "meta": &#123; "versionId": "1574445936024", "lastUpdated": "2019-11-22T18:05:36.024+00:00" &#125;, "clinicalStatus": "inactive", "type": "allergy", "category": [ "medication" ], "code": &#123; "coding": [ &#123; "system": "http://www.nlm.nih.gov/research/umls/rxnorm", "code": "201388", "display": "Demser 250 MG Oral Capsule" &#125; ] &#125;, "patient": &#123; "reference": "Patient/e4ebad5da8814b04a756a144", "display": "Emanuel Emanuel Silva" &#125;, "onsetPeriod": &#123; "start": "2019-11-22T01:00:00+00:00", "end": "2019-11-29T01:30:00+00:00" &#125;, "assertedDate": "2019-11-22T01:00:00+00:00", "recorder": &#123; "reference": "Practitioner/ef8c355d65fb0dd9c2956d7d", "display": "Francis Berrios" &#125;, "reaction": [ &#123; "manifestation": [ &#123; "coding": [ &#123; "system": "http://snomed.info/sct", "code": "2919008", "display": "Nausea/Vomiting/Diarrhea" &#125; ] &#125; ], "severity": "mild" &#125; ] &#125; Updated Allergy generating the error in PUT: &#123; "resourceType":"AllergyIntolerance", "id":"7023d85de188facfe5985755", "meta":&#123; "versionId":"1574445936024", "lastUpdated":"2019-11-22T18:05:36.024+00:00" &#125;, "clinicalStatus":"inactive", "type":"allergy", "category":[ "medication"], "code":&#123; "coding":[ &#123; "system":"http://www.nlm.nih.gov/research/umls/rxnorm", "code":"201388", "display":"Demser 250 MG Oral Capsule" &#125; ] &#125;, "patient":&#123; "reference":"Patient/e4ebad5da8814b04a756a144", "display":"Emanuel Emanuel Silva" &#125;, "onsetPeriod":&#123; "start":"2019-11-22T01:00:00+00:00", "end":"2019-11-29T01:30:00+00:00" &#125;, "assertedDate":"2019-11-22T01:00:00+00:00", "recorder":&#123; "reference":"Practitioner/ef8c355d65fb0dd9c2956d7d", "display":"Francis Berrios" &#125;, "reaction":[ &#123; "manifestation":[ &#123; "coding":[ &#123; "system":"http://snomed.info/sct", "code":"2919008", "display":"Nausea/Vomiting/Diarrhea" &#125; ] &#125; ], "severity":"mild" &#125;, &#123; "manifestation":[ &#123; "coding":[ &#123; "system":"http://snomed.info/sct", "code":"4386001", "display":"Bronchospasm" &#125;] &#125;], "severity":"mild" &#125;] &#125;

Old patient name causing error on family history

Implementing the UI for FamilyHistory i noticed that i could no longer update the information of a patient. i was getting the following error : { "resourceType": "OperationOutcome", "issue": [ { "severity": "error", "code": "processing", "diagnostics": "patientName cannot be modified." } ] } Which was strange because patient name has NOT been changed, in the put (update).Later i noticed that searching FamilyHistory by patient and performing a specific GET in FamilyHistory yield different patient names, for the same patient. example: if i execute this (GET)"FamilyMemberHistory?patient=e4ebad5da8814b04a756a144", the yield JSON is: .....{ "resourceType": "FamilyMemberHistory", "id": "af78c45d8f70aad16f2f16fe", "meta": { "versionId": "1574345827397", "lastUpdated": "2019-11-21T14:17:07.397+00:00" }, "patient": { "reference": "Patient/e4ebad5da8814b04a756a144", "display": "Emanuel Emanuel Silva" },.... but searching for that specific FamilyHistory (GET)"FamilyMemberHistory/af78c45d8f70aad16f2f16fe" results in: .....{ "resourceType": "FamilyMemberHistory", "id": "af78c45d8f70aad16f2f16fe", "meta": { "versionId": "1574345827397", "lastUpdated": "2019-11-21T14:17:07.397+00:00" }, "patient": { "reference": "Patient/e4ebad5da8814b04a756a144", "display": "Testing Allergies" },..... note the difference in the patients names, is this what is causing the error?

Will the clinical code endpoints be available any time soon?

I'm implementing the UI for FHIR data manipulation, for the correct use and validation of the UI we need to populate our fields with these codes. Will the clinical code endpoints be available any time soon? if not, is there any other option for obtaining this resource that is not implementing our own endpoints for clinical codes?

This is awesome!

Love this new developer site and look forward to following the discussions! Health Gorilla