Discussions

Ask a Question

Question about Natural Language Processing API

I have a question about NLP API service. This API is same as google cloud NLP API ? Can i use a sandbox version? Thanks.

Looking for sample of how to request and report a lab test

I'm not yet an HG customer; I'm assessing the effort required to allow one of our customers to request a lab test from us via HG, and then for us to provide the results to them via HG. Note that the results will include not just metadata but also media files.

XSD

Hi, Does Health Gorilla have an XSD that goes with it's API.. Wanted to use that to generate the classes to create API requests with

MEDICAL RECORDS

HOW TO UPLOAD MEDICAL RECORDS THRU THE PORTAL
ANSWERED

White label API and COVID-19

Good morning, I just saw that HealthGorilla was offering electronic ordering of COVID-19 testing via its API. Out of curiosity, would this be possible to employ as white-labeled within a separate app? Our mobile app services 60+ population with hospice care. We thought it would be, at this time, crucially helpful to embed this feature of yours within our app. If this is possible, can you describe next steps? Wishing you well, Trip Levine

Error Updating Allergies

im trying to update an allergy created in the portal, when the PUT endpoint is called i receive the following error: { "resourceType": "OperationOutcome", "issue": [ { "severity": "error", "code": "processing", "diagnostics": "substance cannot be modified." } ] } The substance has not been modified, only a reaction has been added. I've tried to update the Allergy without modifying it (sending in the PUT the same data i receive in the GET), But i still receive the same error. Allergy to be updated: { "resourceType": "AllergyIntolerance", "id": "7023d85de188facfe5985755", "meta": { "versionId": "1574445936024", "lastUpdated": "2019-11-22T18:05:36.024+00:00" }, "clinicalStatus": "inactive", "type": "allergy", "category": [ "medication" ], "code": { "coding": [ { "system": "http://www.nlm.nih.gov/research/umls/rxnorm", "code": "201388", "display": "Demser 250 MG Oral Capsule" } ] }, "patient": { "reference": "Patient/e4ebad5da8814b04a756a144", "display": "Emanuel Emanuel Silva" }, "onsetPeriod": { "start": "2019-11-22T01:00:00+00:00", "end": "2019-11-29T01:30:00+00:00" }, "assertedDate": "2019-11-22T01:00:00+00:00", "recorder": { "reference": "Practitioner/ef8c355d65fb0dd9c2956d7d", "display": "Francis Berrios" }, "reaction": [ { "manifestation": [ { "coding": [ { "system": "http://snomed.info/sct", "code": "2919008", "display": "Nausea/Vomiting/Diarrhea" } ] } ], "severity": "mild" } ] } Updated Allergy generating the error in PUT: { "resourceType":"AllergyIntolerance", "id":"7023d85de188facfe5985755", "meta":{ "versionId":"1574445936024", "lastUpdated":"2019-11-22T18:05:36.024+00:00" }, "clinicalStatus":"inactive", "type":"allergy", "category":[ "medication"], "code":{ "coding":[ { "system":"http://www.nlm.nih.gov/research/umls/rxnorm", "code":"201388", "display":"Demser 250 MG Oral Capsule" } ] }, "patient":{ "reference":"Patient/e4ebad5da8814b04a756a144", "display":"Emanuel Emanuel Silva" }, "onsetPeriod":{ "start":"2019-11-22T01:00:00+00:00", "end":"2019-11-29T01:30:00+00:00" }, "assertedDate":"2019-11-22T01:00:00+00:00", "recorder":{ "reference":"Practitioner/ef8c355d65fb0dd9c2956d7d", "display":"Francis Berrios" }, "reaction":[ { "manifestation":[ { "coding":[ { "system":"http://snomed.info/sct", "code":"2919008", "display":"Nausea/Vomiting/Diarrhea" } ] } ], "severity":"mild" }, { "manifestation":[ { "coding":[ { "system":"http://snomed.info/sct", "code":"4386001", "display":"Bronchospasm" }] }], "severity":"mild" }] }

Old patient name causing error on family history

Implementing the UI for FamilyHistory i noticed that i could no longer update the information of a patient. i was getting the following error : { "resourceType": "OperationOutcome", "issue": [ { "severity": "error", "code": "processing", "diagnostics": "patientName cannot be modified." } ] } Which was strange because patient name has NOT been changed, in the put (update).Later i noticed that searching FamilyHistory by patient and performing a specific GET in FamilyHistory yield different patient names, for the same patient. example: if i execute this (GET)"FamilyMemberHistory?patient=e4ebad5da8814b04a756a144", the yield JSON is: .....{ "resourceType": "FamilyMemberHistory", "id": "af78c45d8f70aad16f2f16fe", "meta": { "versionId": "1574345827397", "lastUpdated": "2019-11-21T14:17:07.397+00:00" }, "patient": { "reference": "Patient/e4ebad5da8814b04a756a144", "display": "Emanuel Emanuel Silva" },.... but searching for that specific FamilyHistory (GET)"FamilyMemberHistory/af78c45d8f70aad16f2f16fe" results in: .....{ "resourceType": "FamilyMemberHistory", "id": "af78c45d8f70aad16f2f16fe", "meta": { "versionId": "1574345827397", "lastUpdated": "2019-11-21T14:17:07.397+00:00" }, "patient": { "reference": "Patient/e4ebad5da8814b04a756a144", "display": "Testing Allergies" },..... note the difference in the patients names, is this what is causing the error?

Will the clinical code endpoints be available any time soon?

I'm implementing the UI for FHIR data manipulation, for the correct use and validation of the UI we need to populate our fields with these codes. Will the clinical code endpoints be available any time soon? if not, is there any other option for obtaining this resource that is not implementing our own endpoints for clinical codes?
ANSWERED

Import Patients via CCD

Is there an endpoint in the API to send single or multiple CCD, that provide us the same functionality as "settings>Patients>Import Patients" in the portal?
ANSWERED

Where is the allergy substance type in JSON response?

In the JSON response given by a specific Allergy GET by ID, I'm trying to find the "Substance type", which can be one of the following based on the ones provided in the portal: No Known Allergies. Allergy to substance. Drug allergy. Drug intolerance. FoodFood allergy. FoodFood Intolerance. Propensity to adverse reactions. Propensity to adverse reactions. Propensity to adverse reactions to drug. Propensity to adverse reactions to food Propensity to adverse reactions to food. none of these are listed in the JSON.